読者です 読者をやめる 読者になる 読者になる

かがりめも

きつねかわいい

【Unity】androidでビルドできなかった話

問題

Unityで作ったやつをiOSでビルドして正しい動きができるの確認できたから,androidでも確認しようとしたらこんなこと言われてビルドが出来なかった.

f:id:krkrkgr:20170217004445p:plain

Unable to install APK!
Installation failed.See the Console for details.

原因

ビルド端末にビルドしようとしたプロジェクトと同じBundle Identifierのアプリが合ったため.

私が詰まった理由は,ビルド端末にビルドしようとしたプロジェクトと同じアプリケーションはなかったものの,名前は違うがBundle Identifierがビルドしようとしたプロジェクトと同じものが合ったせいで原因を見つけるのに時間がかかった.

解決方法

解決方法は2つ考えられると思う

  1. ビルド端末に内にある,現在ビルドしようとしているプロジェクトに設定されているBundle Identifierと同じアプリを消す
  2. Bundle Identifierを変える

多分1が無難

Bundle Identifierの確認方法

Build SettingのPlayer Settingsを押す

f:id:krkrkgr:20170217005936p:plain

Inspector内のOther Settingsの中にある

f:id:krkrkgr:20170217005941p:plain